"An Internal Error Occurred, Please Try Again Later" error message when trying to access "Popular Medical Care Providers Near You"
Incident Report for Human API
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 14:32 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 04, 2021 - 23:16 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 04, 2021 - 15:08 PDT
Investigating
We are currently investigating this issue.
Posted Oct 04, 2021 - 14:21 PDT
This incident affected: Medical.