When users try to access Portal (https://portal.humanapi.co), they encounter a 404 screen.
Incident Report for Human API
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 14:35 PST
Investigating
We are currently investigating this issue.
Posted Feb 10, 2020 - 14:29 PST
This incident affected: Human API Portal.