Password reset is currently not working on the "Developer Portal"
Incident Report for Human API
Resolved
This incident has been resolved.
Posted Aug 28, 2020 - 10:18 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2020 - 08:59 PDT
Update
We are continuing to investigate this issue.
Posted Aug 27, 2020 - 14:42 PDT
Investigating
When a user clicks on "Forgot Password" link on the "Developer Portal", they are not receiving a password reset email.
We apologize for the inconvenience as we continue to investigate.
Posted Aug 27, 2020 - 13:36 PDT
This incident affected: Human API Portal.