Sync errors for new Google Fit connections
Incident Report for Human API
Resolved
This incident has been resolved.
Posted May 22, 2020 - 11:50 PDT
Monitoring
We implemented a request for additional timezone scope that occurs at the Google Fit oauth process. End users can resolve their Google Fit sync errors by reconnecting their account in Human API Connect. New Google Fit users should see the appropriate timezone applied to their data.
Posted May 19, 2020 - 10:06 PDT
Identified
Engineering has identified that the issue relates to timezone information not available for many users at Google Fit's API. As an interim solution, we will begin collecting data for users without a timezone offset applied. While this may produce data via our API that appears different from the user's device, it is still nonetheless the user's data. We will work on a longer term fix thereafter.
Posted May 04, 2020 - 11:09 PDT
Investigating
For some new connections to Google Fit, users may encounter an error syncing their device with Human API. Existing connections should not be affected. We are investigating the problem and will further report as soon as possible. We apologize for the inconvenience and thank you for your patience.
Posted Apr 29, 2020 - 10:51 PDT
This incident affected: Wellness (Google Fit).